rollscnardly
Hello my new friends,  
   
   I'm finally resorting to some outside help on this one after weeks of no luck..... i have a 70' beetle with a recently rebuilt 1600 dp from sab, new generator, distibutor is pn 0231178009 no vacuum advance and a 34pict 3 carb. well first problem is after a week of it sitting battery is drained enough so engine wont turn over which makes me think all the problems im having are electrical but anyways when it is fully charged it fires up fine but wont stay at idle  ive spent many hours trying to set the carb right but wont drop to correct idle speed without dying. ive heard the 34 pict 3 carb is a pain to work with and thought the problems might involve the distibutor im using.   any help or suggestions are greatly appreciated   thanks much!

70' Std. Bug
Quote 0 0
olspeed
First thing to check is the idle cutoff solenoid. On the side of the carb opposite of the choke dash-pot there is a solenoid... you should have a wire that runs from the + side of the coil to this solenoid and then to the choke. First make sure the wire is there and that it is hooked up. Then with the engine not running but the key on. go back to the engine and pull the wire from the cutoff solenoid and touch it Back to the spade there. It should "click" this would mean that it is working. If not that is your idle problem. 
Oilseed
66 Ghia 76 std Beetle
It's not a car it's a VolksWagon
Quote 0 0
rollscnardly
yah its clicking
70' Std. Bug
Quote 0 0
rollscnardly
k so ive been doing my homework and found out that the 34pict carb runs best with the svda distributor which costs a little more bread than i can afford right now. ...but i still have my h30/31 brosel from the original engine that was on the car when i bought it which happens to be a 1300 65' even though the car is a 70'...so my question which distributor works best with the H30/31 and how do i need it jetted?
70' Std. Bug
Quote 0 0