73BeetleBug
I am brand new the air cooled community because as of friday night i purchased a 73 Beetle. I have always wanted one and finally had the chance to grab one. i am excited to get started restoring her and making her shine like a new penny. 

I do have one question it does run but when i start her up she does not want to idle by herself for like 5-10 minutes. I was wondering what this problem could be. Any idea of where i can start looking would be awesome. Thanks!!!!
Click image for larger version - Name: IMG-20111106-00047.jpg, Views: 16, Size: 452.17 KB Click image for larger version - Name: IMG-20111106-00045.jpg, Views: 16, Size: 406.73 KB Click image for larger version - Name: IMG-20111106-00046.jpg, Views: 15, Size: 401.37 KB Click image for larger version - Name: IMG-20111106-00049.jpg, Views: 22, Size: 411.12 KB Click image for larger version - Name: IMG-20111106-00048.jpg, Views: 15, Size: 419.24 KB
Quote 0 0
Wayne
That's a great looking Beetle. Has it been sitting for a while? If so I'd suggest a tuneup and fresh gas for a start.
Quote 0 0
73BeetleBug
Yea it was sitting for about a year. I put new gas in it and i am trying to research into giving it a tune up. It seems the more and more i start her up the better she gets at running on her own. Yesterday it took her like 2 minutes to idle on her own. 
Quote 0 0
Wayne
A tuneup on a Beetle is easy. Plugs, wires, distributor cap, points and condenser. I would also suggest upgrading to an electronic ignition like Pertronix.
Quote 0 0
73BeetleBug
well i have also discovered that someone must have put after market intake manifolds and carbs which apparently do not have electronic cokes from what the dude who rebuilt the engine told me. so i started to take them off and i am gonna revert it back to stock with a single carb. i dont want to have to deal with syncing dual carbs.
Quote 0 0